What’s Vulnerable › Vulnerabilities
CVE-2023-45147: Arbitrary keys can be added to a topic's custom fields by any user in Discourse
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-16 · updated 2026-06-17
- Weakness: CWE-200
Description
Discourse is an open source community platform. In affected versions any user can create a topic and add arbitrary custom fields to a topic. The severity of this vulnerability depends on what plugins are installed and how the plugins uses topic custom fields. For a default Discourse installation with the default plugins, this vulnerability has no impact. The problem has been patched in the latest version of Discourse. Users are advised to update to version 3.1.1 if they are on the stable branch or 3.2.0.beta2 if they are on the beta branch. Users unable to upgrade should disable any plugins that access topic custom fields.
Affected products
- discourse: through 3.1.1; 3.2.0-beta1
References
- https://github.com/discourse/discourse/security/advisories/GHSA-wm89-m359-f9qv
- https://github.com/discourse/discourse/security/advisories/GHSA-wm89-m359-f9qv
Get alerted when CVE-2023-45147 or the next vulnerability affects your stack