What’s Vulnerable › Vulnerabilities
CVE-2023-45149: Password of talk conversations can be bruteforced in Nextcloud
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-16 · updated 2026-06-17
- Weakness: CWE-307
Description
Nextcloud talk is a chat module for the Nextcloud server platform. In affected versions brute force protection of public talk conversation passwords can be bypassed, as there was an endpoint validating the conversation password without registering bruteforce attempts. It is recommended that the Nextcloud Talk app is upgraded to 15.0.8, 16.0.6 or 17.1.1. There are no known workarounds for this vulnerability.
Affected products
- Nextcloud Talk: from 15.0.0 before 15.0.8; from 16.0.0 before 16.0.6; from 17.0.0 before 17.1.1 — fixed in 15.0.8, 16.0.6, 17.1.1
How to fix
Upgrade to a fixed version: Nextcloud Talk 15.0.8, 16.0.6, 17.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-7rf8-pqmj-rpqv
- https://github.com/nextcloud/spreed/pull/10545
- https://hackerone.com/reports/2094473
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-7rf8-pqmj-rpqv
- https://github.com/nextcloud/spreed/pull/10545
- https://hackerone.com/reports/2094473
Get alerted when CVE-2023-45149 or the next vulnerability affects your stack