What’s Vulnerable › Vulnerabilities
CVE-2023-45177: IBM MQ denial of service
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-20 · updated 2026-06-17
- Weakness: CWE-20
Description
IBM MQ 9.0 LTS, 9.1 LTS, 9.2 LTS, 9.3 LTS and 9.3 CD is vulnerable to a denial-of-service attack due to an error within the MQ clustering logic. IBM X-Force ID: 268066.
Affected products
- IBM MQ: from 9.0.0.0 before 9.0.0.21; from 9.1.0.0 before 9.1.0.18; from 9.2.0.0 before 9.2.0.20; from 9.3.0 before 9.3.4; from 9.3.0.0 through 9.3.0.10 — fixed in 9.0.0.21, 9.1.0.18, 9.2.0.20, 9.3.4
How to fix
Upgrade to a fixed version: IBM MQ 9.0.0.21, 9.1.0.18, 9.2.0.20, 9.3.4. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/268066
- https://www.ibm.com/support/pages/node/7063661
- https://exchange.xforce.ibmcloud.com/vulnerabilities/268066
- https://www.ibm.com/support/pages/node/7063661
Get alerted when CVE-2023-45177 or the next vulnerability affects your stack