What’s Vulnerable › Vulnerabilities
CVE-2023-45193: IBM Db2 denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-22 · updated 2026-06-17
- Weakness: CWE-20
Description
IBM Db2 for Linux, UNIX and Windows (includes Db2 Connect Server) 11.5 federated server is vulnerable to a denial of service when a specially crafted cursor is used. IBM X-Force ID: 268759.
Affected products
- IBM Db2 for Linux, UNIX and Windows: before 11.5.9 — fixed in 11.5.9
How to fix
Upgrade to a fixed version: IBM Db2 for Linux, UNIX and Windows 11.5.9. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/268759
- https://security.netapp.com/advisory/ntap-20240307-0001/
- https://www.ibm.com/support/pages/node/7105501
- https://exchange.xforce.ibmcloud.com/vulnerabilities/268759
- https://security.netapp.com/advisory/ntap-20240307-0001/
- https://www.ibm.com/support/pages/node/7105501
Get alerted when CVE-2023-45193 or the next vulnerability affects your stack