What’s Vulnerable › Vulnerabilities
CVE-2023-45195: Adminer and AdminerEvo SSRF
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-24 · updated 2026-06-17
- Weakness: CWE-918
Description
Adminer and AdminerEvo are vulnerable to SSRF via database connection fields. This could allow an unauthenticated remote attacker to enumerate or access systems the attacker would not otherwise have access to. Adminer is no longer supported, but this issue was fixed in AdminerEvo version 4.8.4.
Affected products
- AdminerEvo: before 4.8.4 — fixed in 4.8.4
How to fix
Upgrade to a fixed version: AdminerEvo 4.8.4. Check the vendor advisory for mitigations.
References
- https://github.com/adminerevo/adminerevo/pull/102/commits/18f3167bbcbec3bc746f62db72e016aa99144efc
- https://github.com/adminerevo/adminerevo/pull/102/commits/18f3167bbcbec3bc746f62db72e016aa99144efc
Get alerted when CVE-2023-45195 or the next vulnerability affects your stack