What’s Vulnerable › Vulnerabilities
CVE-2023-45348: Apache Airflow: Configuration information leakage vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-14 · updated 2026-06-17
- Weakness: CWE-200
Description
Apache Airflow, versions 2.7.0 and 2.7.1, is affected by a vulnerability that allows an authenticated user to retrieve sensitive configuration information when the "expose_config" option is set to "non-sensitive-only". The `expose_config` option is False by default. It is recommended to upgrade to a version that is not affected.
Affected products
- Apache Airflow: from 2.7.0 before 2.7.2 — fixed in 2.7.2
How to fix
Upgrade to a fixed version: Apache Airflow 2.7.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/10/23/2
- https://github.com/apache/airflow/pull/34712
- https://lists.apache.org/thread/sy4l5d6tn58hr8r61r2fkt1f0qock9z9
- http://www.openwall.com/lists/oss-security/2023/10/23/2
- https://github.com/apache/airflow/pull/34712
- https://lists.apache.org/thread/sy4l5d6tn58hr8r61r2fkt1f0qock9z9
Get alerted when CVE-2023-45348 or the next vulnerability affects your stack