What’s Vulnerable › Vulnerabilities
CVE-2023-45360
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-03 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. There is XSS in youhavenewmessagesmanyusers and youhavenewmessages i18n messages. This is related to MediaWiki:Youhavenewmessagesfromusers.
Affected products
- Wikimedia Foundation MediaWiki: before 1.35.12; from 1.39.0 before 1.39.5; 1.40.0, 1.40.0-rc0 — fixed in 1.35.12, 1.39.5
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.35.12, 1.39.5. Check the vendor advisory for mitigations.
References
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/
- https://phabricator.wikimedia.org/T340221
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/
- https://phabricator.wikimedia.org/T340221
Get alerted when CVE-2023-45360 or the next vulnerability affects your stack