What’s Vulnerable › Vulnerabilities
CVE-2023-45363
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 23.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-09 · updated 2026-06-17
- Weakness: CWE-835
Description
An issue was discovered in ApiPageSet.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. It allows attackers to cause a denial of service (unbounded loop and RequestTimeoutException) when querying pages redirected to other variants with redirects and converttitles set.
Affected products
- Debian Linux: 11.0, 12.0
- Wikimedia Foundation MediaWiki: before 1.35.12; from 1.36.0 before 1.39.5; 1.40.0 — fixed in 1.35.12, 1.39.5
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.35.12, 1.39.5. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2023/11/msg00027.html
- https://phabricator.wikimedia.org/T333050
- https://www.debian.org/security/2023/dsa-5520
- https://lists.debian.org/debian-lts-announce/2023/11/msg00027.html
- https://phabricator.wikimedia.org/T333050
- https://www.debian.org/security/2023/dsa-5520
Get alerted when CVE-2023-45363 or the next vulnerability affects your stack