What’s Vulnerable › Vulnerabilities
CVE-2023-45372
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-09 · updated 2026-06-17
- Weakness: CWE-693
Description
An issue was discovered in the Wikibase extension for MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. During item merging, ItemMergeInteractor does not have an edit filter running (e.g., AbuseFilter).
Affected products
- Wikimedia Foundation MediaWiki: before 1.35.12; from 1.36.0 before 1.39.5; 1.40.0 — fixed in 1.35.12, 1.39.5
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.35.12, 1.39.5. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Wikibase/+/961264
- https://phabricator.wikimedia.org/T345064
- https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Wikibase/+/961264
- https://phabricator.wikimedia.org/T345064
Get alerted when CVE-2023-45372 or the next vulnerability affects your stack