What’s Vulnerable › Vulnerabilities
CVE-2023-45375
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 41.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-17 · updated 2026-06-17
- Weakness: CWE-89
Description
In the module "PireosPay" (pireospay) before version 1.7.10 from 01generator.com for PrestaShop, a guest can perform SQL injection via `PireosPayValidationModuleFrontController::postProcess().`
Affected products
- 01Generator Pireospay: before 1.7.10 — fixed in 1.7.10
How to fix
Upgrade to a fixed version: 01Generator Pireospay 1.7.10. Check the vendor advisory for mitigations.
References
- https://security.friendsofpresta.org/modules/2023/10/12/pireospay.html
- https://security.friendsofpresta.org/modules/2023/10/12/pireospay.html
Get alerted when CVE-2023-45375 or the next vulnerability affects your stack