What’s Vulnerable › Vulnerabilities
CVE-2023-45471
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The QAD Search Server is vulnerable to Stored Cross-Site Scripting (XSS) in versions up to, and including, 1.0.0.315 due to insufficient checks on indexes. This makes it possible for unauthenticated attackers to create a new index and inject a malicious web script into its name, that will execute whenever a user accesses the search page.
Affected products
- Qad Search Server: before 1.0.0.315 — fixed in 1.0.0.315
How to fix
Upgrade to a fixed version: Qad Search Server 1.0.0.315. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-45471 or the next vulnerability affects your stack