What’s Vulnerable › Vulnerabilities
CVE-2023-4549: DoLogin Security < 3.7 - Unauthenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The DoLogin Security WordPress plugin before 3.7 does not properly sanitize IP addresses coming from the X-Forwarded-For header, which can be used by attackers to conduct Stored XSS attacks via WordPress' login form.
Affected products
- DoLogin Security: before 3.7 — fixed in 3.7
How to fix
Upgrade to a fixed version: DoLogin Security 3.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8aebead0-0eab-4d4e-8ceb-8fea0760374f
- https://wpscan.com/vulnerability/8aebead0-0eab-4d4e-8ceb-8fea0760374f
Get alerted when CVE-2023-4549 or the next vulnerability affects your stack