What’s Vulnerable › Vulnerabilities
CVE-2023-45539
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-28 · updated 2026-06-17
- Weakness: CWE-116
Description
HAProxy before 2.8.2 accepts # as part of the URI component, which might allow remote attackers to obtain sensitive information or have unspecified other impact upon misinterpretation of a path_end rule, such as routing index.html#.png to a static server.
Affected products
- HAProxy: before 2.8.2 — fixed in 2.8.2
How to fix
Upgrade to a fixed version: HAProxy 2.8.2. Check the vendor advisory for mitigations.
References
- https://git.haproxy.org/?p=haproxy.git%3Ba=commit%3Bh=2eab6d354322932cfec2ed54de261e4347eca9a6
- https://lists.debian.org/debian-lts-announce/2023/12/msg00010.html
- https://lists.w3.org/Archives/Public/ietf-http-wg/2023JulSep/0070.html
- https://www.mail-archive.com/haproxy%40formilux.org/msg43861.html
- https://git.haproxy.org/?p=haproxy.git%3Ba=commit%3Bh=2eab6d354322932cfec2ed54de261e4347eca9a6
- https://lists.debian.org/debian-lts-announce/2023/12/msg00010.html
- https://lists.w3.org/Archives/Public/ietf-http-wg/2023JulSep/0070.html
- https://www.mail-archive.com/haproxy%40formilux.org/msg43861.html
Get alerted when CVE-2023-45539 or the next vulnerability affects your stack