What’s Vulnerable › Vulnerabilities
CVE-2023-45584
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-12 · updated 2026-06-17
- Weakness: CWE-415
Description
A double free vulnerability [CWE-415] vulnerability in Fortinet FortiOS 7.4.0, FortiOS 7.2.0 through 7.2.5, FortiOS 7.0.0 through 7.0.12, FortiOS 6.4 all versions, FortiPAM 1.1 all versions, FortiPAM 1.0 all versions, FortiProxy 7.4.0 through 7.4.1, FortiProxy 7.2.0 through 7.2.7, FortiProxy 7.0.0 through 7.0.13 allows a privileged attacker to execute code or commands via crafted HTTP or HTTPs requests.
Affected products
- Fortinet FortiOS (FortiGate): from 6.4.0 before 7.0.13; from 7.2.0 before 7.2.6; 7.4.0 — fixed in 7.0.13, 7.2.6
- Fortinet FortiPAM: from 1.0.0 through 1.1.2
- Fortinet FortiProxy: from 7.0.0 before 7.0.14; from 7.2.0 before 7.2.8; from 7.4.0 before 7.4.2 — fixed in 7.0.14, 7.2.8, 7.4.2
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 7.0.13, 7.2.6; Fortinet FortiProxy 7.0.14, 7.2.8, 7.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-45584 or the next vulnerability affects your stack