What’s Vulnerable › Vulnerabilities
CVE-2023-45591
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-05 · updated 2026-06-17
- Weakness: CWE-122
Description
A CWE-122 “Heap-based Buffer Overflow” vulnerability in the “logger_generic” function of the “Ax_rtu” binary allows a remote authenticated attacker to trigger a memory corruption in the context of the binary. This may result in a Denial-of-Service (DoS) condition, possibly in the execution of arbitrary code with the same privileges of the process (root), or have other unspecified impacts on the device. This issue affects: AiLux imx6 bundle below version imx6_1.0.7-2.
Affected products
- AiLux imx6 bundle: before 1.0.7-2 — fixed in 1.0.7-2
How to fix
Upgrade to a fixed version: AiLux imx6 bundle 1.0.7-2. Check the vendor advisory for mitigations.
References
- https://www.nozominetworks.com/labs/vulnerability-advisories-cve-2023-45591
- https://www.nozominetworks.com/labs/vulnerability-advisories-cve-2023-45591
Get alerted when CVE-2023-45591 or the next vulnerability affects your stack