What’s Vulnerable › Vulnerabilities
CVE-2023-45617
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-14 · updated 2026-06-17
Description
There are arbitrary file deletion vulnerabilities in the CLI service accessed by PAPI (Aruba's access point management protocol). Successful exploitation of these vulnerabilities result in the ability to delete arbitrary files on the underlying operating system, which could lead to the ability to interrupt normal operation and impact the integrity of the access point.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 10.3.0.0 before 10.4.0.3; 10.5.0.0 — fixed in 10.4.0.3
- Hewlett Packard Enterprise (HPE) HPE Aruba Networking InstantOS and Aruba Access Points running ArubaOS 10: from 6.4.0.0 before 8.6.0.23; from 8.10.0.0 before 8.10.0.9; from 8.11.0.0 before 8.11.2.0 — fixed in 8.10.0.9, 8.11.2.0, 8.6.0.23
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 10.4.0.3; Hewlett Packard Enterprise (HPE) HPE Aruba Networking InstantOS and Aruba Access Points running ArubaOS 10 8.10.0.9, 8.11.2.0, 8.6.0.23. Check the vendor advisory for mitigations.
References
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2023-017.txt
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2023-017.txt
Get alerted when CVE-2023-45617 or the next vulnerability affects your stack