What’s Vulnerable › Vulnerabilities

CVE-2023-45648: Apache Tomcat: Trailer header parsing too lenient

Description

Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from 9.0.0-M1 through 9.0.81 and from 8.5.0 through 8.5.93 did not correctly parse HTTP trailer headers. A specially crafted, invalid trailer header could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M12 onwards, 10.1.14 onwards, 9.0.81 onwards or 8.5.94 onwards, which fix the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Tomcat 10.1.14, 8.5.94, 9.0.81. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-45648 or the next vulnerability affects your stack