What’s Vulnerable › Vulnerabilities
CVE-2023-45660: Require strict cookies for image proxy requests in Nextcloud Mail
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-16 · updated 2026-06-17
- Weakness: CWE-918
Description
Nextcloud mail is an email app for the Nextcloud home server platform. In affected versions a missing check of origin, target and cookies allows for an attacker to abuse the proxy endpoint to denial of service a third server. It is recommended that the Nextcloud Mail is upgraded to 2.2.8 or 3.3.0. There are no known workarounds for this vulnerability.
Affected products
- nextcloud Mail: from 2.2.0 before 2.2.8; from 3.0.0 before 3.3.0 — fixed in 2.2.8, 3.3.0
How to fix
Upgrade to a fixed version: nextcloud Mail 2.2.8, 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/mail/pull/8459
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-8j9x-fmww-qr37
- https://hackerone.com/reports/1895874
- https://github.com/nextcloud/mail/pull/8459
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-8j9x-fmww-qr37
- https://hackerone.com/reports/1895874
Get alerted when CVE-2023-45660 or the next vulnerability affects your stack