What’s Vulnerable › Vulnerabilities
CVE-2023-4570: Improper Restriction in NI MeasurementLink Python Services
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-05 · updated 2026-06-17
- Weakness: CWE-420
Description
An improper access restriction in NI MeasurementLink Python services could allow an attacker on an adjacent network to reach services exposed on localhost. These services were previously thought to be unreachable outside of the node. This affects measurement plug-ins written in Python using version 1.1.0 of the ni-measurementlink-service Python package and all previous versions.
Affected products
- NI MeasurementLink: from 1.0.0 before 1.1.1 — fixed in 1.1.1
How to fix
Upgrade to a fixed version: NI MeasurementLink 1.1.1. Check the vendor advisory for mitigations.
References
- https://www.ni.com/en/support/documentation/supplemental/23/improper-restriction-in-ni-measurementlink-python-services.html
- https://www.ni.com/en/support/documentation/supplemental/23/improper-restriction-in-ni-measurementlink-python-services.html
Get alerted when CVE-2023-4570 or the next vulnerability affects your stack