What’s Vulnerable › Vulnerabilities

CVE-2023-45727: North Grid Proself Improper Restriction of XML External Entity (XXE) Reference Vulnerability

Description

Proself Enterprise/Standard Edition Ver5.62 and earlier, Proself Gateway Edition Ver1.65 and earlier, and Proself Mail Sanitize Edition Ver1.08 and earlier allow a remote unauthenticated attacker to conduct XML External Entity (XXE) attacks. By processing a specially crafted request containing malformed XML data, arbitrary files on the server containing account information may be read by the attacker.

Affected products

How to fix

Upgrade to a fixed version: Northgrid Proself 1.09, 1.66, 5.63. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-45727 or the next vulnerability affects your stack