What’s Vulnerable › Vulnerabilities
CVE-2023-45796: XSS vulnerability in Pilz PASvisu and PMI v8xx
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-22 · updated 2026-09-26
- Weakness: CWE-79
Description
A stored cross-site scripting vulnerability in the Runtime component of Pilz PASvisu before 1.14.1 and PMI v8xx up to and including 2.0.33992 allows a low-privileged remote unauthenticated attacker to manipulate process data with potential impact on integrity and/or availability.
Affected products
- Pilz PASvisu: before 1.14.1 — fixed in 1.14.1
- Pilz PMI v8xx: through 2.0.33992
How to fix
Upgrade to a fixed version: Pilz PASvisu 1.14.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-45796 or the next vulnerability affects your stack