What’s Vulnerable › Vulnerabilities
CVE-2023-45810: OpenFGA denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-17 · updated 2026-06-17
- Weakness: CWE-400
Description
OpenFGA is a flexible authorization/permission engine built for developers and inspired by Google Zanzibar. Affected versions of OpenFGA are vulnerable to a denial of service attack. When a number of `ListObjects` calls are executed, in some scenarios, those calls are not releasing resources even after a response has been sent, and given a sufficient call volume the service as a whole becomes unresponsive. This issue has been addressed in version 1.3.4 and the upgrade is considered backwards compatible. There are no known workarounds for this vulnerability.
Affected products
- openfga: before 1.3.4 — fixed in 1.3.4
How to fix
Upgrade to a fixed version: openfga 1.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/openfga/openfga/security/advisories/GHSA-hr4f-6jh8-f2vq
- https://github.com/openfga/openfga/security/advisories/GHSA-hr4f-6jh8-f2vq
Get alerted when CVE-2023-45810 or the next vulnerability affects your stack