What’s Vulnerable › Vulnerabilities
CVE-2023-45821: Incorrect Docker Hub registry check in Artifact Hub
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-19 · updated 2026-06-17
- Weakness: CWE-494
Description
Artifact Hub is a web-based application that enables finding, installing, and publishing packages and configurations for CNCF projects. During a security audit of Artifact Hub's code base a security researcher identified a bug in which the `registryIsDockerHub` function was only checking that the registry domain had the `docker.io` suffix. Artifact Hub allows providing some Docker credentials that are used to increase the rate limit applied when interacting with the Docker Hub registry API to read publicly available content. Due to the incorrect check described above, it'd be possible to hijack those credentials by purchasing a domain which ends with `docker.io` and deploying a fake OCI registry on it. <https://artifacthub.io/> uses some credentials that only have permissions to read public content available in the Docker Hub. However, even though credentials for private repositories (disabled on `artifacthub.io`) are handled in a different way, other Artifact Hub deployments could have been using them for a different purpose. This issue has been resolved in version `1.16.0`. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- artifacthub hub: before 1.16.0 — fixed in 1.16.0
How to fix
Upgrade to a fixed version: artifacthub hub 1.16.0. Check the vendor advisory for mitigations.
References
- https://artifacthub.io/packages/helm/artifact-hub/artifact-hub?modal=changelog&version=1.16.0
- https://github.com/artifacthub/hub/security/advisories/GHSA-g6pq-x539-7w4j
- https://artifacthub.io/packages/helm/artifact-hub/artifact-hub?modal=changelog&version=1.16.0
- https://github.com/artifacthub/hub/security/advisories/GHSA-g6pq-x539-7w4j
Get alerted when CVE-2023-45821 or the next vulnerability affects your stack