What’s Vulnerable › Vulnerabilities
CVE-2023-45859
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-28 · updated 2026-06-17
- Weakness: CWE-922
Description
In Hazelcast through 4.1.10, 4.2 through 4.2.8, 5.0 through 5.0.5, 5.1 through 5.1.7, 5.2 through 5.2.4, and 5.3 through 5.3.2, some client operations don't check permissions properly, allowing authenticated users to access data stored in the cluster.
Affected products
- hazelcast: through 4.1.10; from 4.2.0 through 4.2.8; from 5.0.0 through 5.0.5; from 5.1.0 through 5.1.7; from 5.2.0 before 5.2.5; from 5.3.0 before 5.3.5 — fixed in 5.2.5, 5.3.5
How to fix
Upgrade to a fixed version: hazelcast 5.2.5, 5.3.5. Check the vendor advisory for mitigations.
References
- https://github.com/hazelcast/hazelcast/pull/25509
- https://github.com/hazelcast/hazelcast/security/advisories/GHSA-xh6m-7cr7-xx66
- https://github.com/hazelcast/hazelcast/pull/25509
- https://github.com/hazelcast/hazelcast/security/advisories/GHSA-xh6m-7cr7-xx66
Get alerted when CVE-2023-45859 or the next vulnerability affects your stack