What’s Vulnerable › Vulnerabilities
CVE-2023-45871
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-15 · updated 2026-10-15
- Weakness: CWE-131
Description
An issue was discovered in drivers/net/ethernet/intel/igb/igb_main.c in the IGB driver in the Linux kernel before 6.5.3. A buffer size may not be adequate for frames larger than the MTU.
Affected products
- Debian Linux: 10.0
- Linux kernel: from 3.4 before 4.14.326; from 4.15 before 4.19.295; from 4.20 before 5.4.257; from 5.5 before 5.10.195; from 5.11 before 5.15.132; from 5.16 before 6.1.53 — fixed in 4.14.326, 4.19.295, 5.10.195, 5.15.132, 5.4.257, 6.1.53
How to fix
Upgrade to a fixed version: Linux kernel 4.14.326, 4.19.295, 5.10.195, 5.15.132. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v6.x/ChangeLog-6.5.3
- https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=bb5ed01cd2428cd25b1c88a3a9cba87055eb289f
- https://lists.debian.org/debian-lts-announce/2024/01/msg00004.html
- https://security.netapp.com/advisory/ntap-20231110-0001/
- https://cdn.kernel.org/pub/linux/kernel/v6.x/ChangeLog-6.5.3
- https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=bb5ed01cd2428cd25b1c88a3a9cba87055eb289f
- https://lists.debian.org/debian-lts-announce/2024/01/msg00004.html
- https://security.netapp.com/advisory/ntap-20231110-0001/
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://cert-portal.siemens.com/productcert/html/ssa-794697.html
Get alerted when CVE-2023-45871 or the next vulnerability affects your stack