What’s Vulnerable › Vulnerabilities
CVE-2023-45957
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-22 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored cross-site scripting (XSS) vulnerability in the component admin/AdminRequestSqlController.php of thirty bees before 1.5.0 allows attackers to execute arbitrary web script or HTML via $e->getMessage() error mishandling.
Affected products
- Thirtybees Thirty Bees: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: Thirtybees Thirty Bees 1.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/thirtybees/thirtybees/commit/f5b2c1e0094ce53fded1443bab99a604ae8e2968
- https://github.com/thirtybees/thirtybees/compare/1.4.0...1.5.0
- https://zigrin.com/advisories/thirty-bees-stored-cross-site-scripting-xss/
- https://github.com/thirtybees/thirtybees/commit/f5b2c1e0094ce53fded1443bab99a604ae8e2968
- https://github.com/thirtybees/thirtybees/compare/1.4.0...1.5.0
- https://zigrin.com/advisories/thirty-bees-stored-cross-site-scripting-xss/
Get alerted when CVE-2023-45957 or the next vulnerability affects your stack