What’s Vulnerable › Vulnerabilities
CVE-2023-4599: Email Encoder <= 2.1.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The Email Encoder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'eeb_mailto' shortcode in versions up to, and including, 2.1.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A partial patch was issued in version 2.1.8. The vulnerability was fully patched in 2.1.9.
Affected products
- Email Encoder: through 2.1.7
References
- https://plugins.trac.wordpress.org/browser/email-encoder-bundle/tags/2.1.7/core/includes/classes/class-email-encoder-bundle-run.php#L529
- https://plugins.trac.wordpress.org/changeset/2958823/email-encoder-bundle#file60
- https://plugins.trac.wordpress.org/changeset/2994384/email-encoder-bundle/trunk?contextall=1&old=2958823&old_path=%2Femail-encoder-bundle%2Ftrunk#file0
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e90f04e4-eb4c-4822-89c6-79f553987c37?source=cve
- https://plugins.trac.wordpress.org/browser/email-encoder-bundle/tags/2.1.7/core/includes/classes/class-email-encoder-bundle-run.php#L529
- https://plugins.trac.wordpress.org/changeset/2958823/email-encoder-bundle#file60
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e90f04e4-eb4c-4822-89c6-79f553987c37?source=cve
Get alerted when CVE-2023-4599 or the next vulnerability affects your stack