What’s Vulnerable › Vulnerabilities
CVE-2023-4602: Namaste! LMS <= 2.6.1.1 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Namaste! LMS plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'course_id' parameter in versions up to, and including, 2.6.1.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- Bob Namaste! LMS: before 2.6.1.2 — fixed in 2.6.1.2
How to fix
Upgrade to a fixed version: Bob Namaste! LMS 2.6.1.2. Check the vendor advisory for mitigations.
References
- https://drive.google.com/file/d/1wliD7YvLqL2xWnR6jLEnWgoWRKsv9dCI/view?usp=sharing
- https://plugins.trac.wordpress.org/changeset/2966178/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d014f512-9030-49ce-945d-4900594fb373?source=cve
- https://drive.google.com/file/d/1wliD7YvLqL2xWnR6jLEnWgoWRKsv9dCI/view?usp=sharing
- https://plugins.trac.wordpress.org/changeset/2966178/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d014f512-9030-49ce-945d-4900594fb373?source=cve
Get alerted when CVE-2023-4602 or the next vulnerability affects your stack