What’s Vulnerable › Vulnerabilities
CVE-2023-4603: Star CloudPRNT for WooCommerce <= 2.0.3 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Star CloudPRNT for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'printersettings' parameter in versions up to, and including, 2.0.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- lawrenceowen, gcubero, acunnningham, fmahmood Star CloudPRNT for WooCommerce: before 2.0.4 — fixed in 2.0.4
How to fix
Upgrade to a fixed version: lawrenceowen, gcubero, acunnningham, fmahmood Star CloudPRNT for WooCommerce 2.0.4. Check the vendor advisory for mitigations.
References
- https://drive.google.com/file/d/1cRVH7Oz6M2U2XTbNAmm43PDKBw6FzShA/view?usp=sharing
- https://plugins.trac.wordpress.org/changeset/2991002/star-cloudprnt-for-woocommerce/trunk?contextall=1&old=2510015&old_path=%2Fstar-cloudprnt-for-woocommerce%2Ftrunk
- https://www.wordfence.com/threat-intel/vulnerabilities/id/110c6d41-e814-41c9-a3e7-d94ec3d953e6?source=cve
- https://drive.google.com/file/d/1cRVH7Oz6M2U2XTbNAmm43PDKBw6FzShA/view?usp=sharing
- https://plugins.trac.wordpress.org/changeset/2991002/star-cloudprnt-for-woocommerce/trunk?contextall=1&old=2510015&old_path=%2Fstar-cloudprnt-for-woocommerce%2Ftrunk
- https://www.wordfence.com/threat-intel/vulnerabilities/id/110c6d41-e814-41c9-a3e7-d94ec3d953e6?source=cve
Get alerted when CVE-2023-4603 or the next vulnerability affects your stack