What’s Vulnerable › Vulnerabilities
CVE-2023-46104: Apache Superset: Allows for uncontrolled resource consumption via a ZIP bomb
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-19 · updated 2026-06-17
- Weakness: CWE-400
Description
Uncontrolled resource consumption can be triggered by authenticated attacker that uploads a malicious ZIP to import database, dashboards or datasets. This vulnerability exists in Apache Superset versions up to and including 2.1.2 and versions 3.0.0, 3.0.1.
Affected products
- Apache Superset: before 2.1.3; from 3.0.0 before 3.0.1 — fixed in 2.1.3, 3.0.1
How to fix
Upgrade to a fixed version: Apache Superset 2.1.3, 3.0.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/12/19/1
- http://www.openwall.com/lists/oss-security/2024/02/14/2
- http://www.openwall.com/lists/oss-security/2024/02/14/3
- https://lists.apache.org/thread/yxbxg4wryb7cb7wyybk11l5nqy0rsrvl
- http://www.openwall.com/lists/oss-security/2023/12/19/1
- http://www.openwall.com/lists/oss-security/2024/02/14/2
- http://www.openwall.com/lists/oss-security/2024/02/14/3
- https://lists.apache.org/thread/yxbxg4wryb7cb7wyybk11l5nqy0rsrvl
Get alerted when CVE-2023-46104 or the next vulnerability affects your stack