What’s Vulnerable › Vulnerabilities
CVE-2023-46118: Denial of Service by publishing large messages over the HTTP API
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-24 · updated 2026-06-17
- Weakness: CWE-400
Description
RabbitMQ is a multi-protocol messaging and streaming broker. HTTP API did not enforce an HTTP request body limit, making it vulnerable for denial of service (DoS) attacks with very large messages. An authenticated user with sufficient credentials can publish a very large messages over the HTTP API and cause target node to be terminated by an "out-of-memory killer"-like mechanism. This vulnerability has been patched in versions 3.11.24 and 3.12.7.
Affected products
- VMware Tanzu RabbitMQ: before 3.11.24; from 3.12.0 before 3.12.7 — fixed in 3.11.24, 3.12.7
- rabbitmq-server: before 3.12.7; before 3.11.24
How to fix
Upgrade to a fixed version: VMware Tanzu RabbitMQ 3.11.24, 3.12.7. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-w6cq-9cf4-gqpg
- https://lists.debian.org/debian-lts-announce/2023/12/msg00009.html
- https://www.debian.org/security/2023/dsa-5571
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-w6cq-9cf4-gqpg
- https://lists.debian.org/debian-lts-announce/2023/12/msg00009.html
- https://www.debian.org/security/2023/dsa-5571
Get alerted when CVE-2023-46118 or the next vulnerability affects your stack