What’s Vulnerable › Vulnerabilities
CVE-2023-46123: jumpserver is vulnerable to password brute-force protection bypass via arbitrary IP values
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-25 · updated 2026-06-17
- Weakness: CWE-307
Description
jumpserver is an open source bastion machine, professional operation and maintenance security audit system that complies with 4A specifications. A flaw in the Core API allows attackers to bypass password brute-force protections by spoofing arbitrary IP addresses. By exploiting this vulnerability, attackers can effectively make unlimited password attempts by altering their apparent IP address for each request. This vulnerability has been patched in version 3.8.0.
Affected products
- jumpserver: before 3.8.0 — fixed in 3.8.0
How to fix
Upgrade to a fixed version: jumpserver 3.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/jumpserver/jumpserver/releases/tag/v3.8.0
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-hvw4-766m-p89f
- https://www.sonarsource.com/blog/diving-into-jumpserver-attackers-gateway-to-internal-networks-1-2
- https://github.com/jumpserver/jumpserver/releases/tag/v3.8.0
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-hvw4-766m-p89f
Get alerted when CVE-2023-46123 or the next vulnerability affects your stack