What’s Vulnerable › Vulnerabilities
CVE-2023-46124: Server-Side Request Forgery Vulnerability in Custom Integration Upload
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-25 · updated 2026-06-17
- Weakness: CWE-918
Description
Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in runtime environments, and the enforcement of privacy regulations in code. The Fides web application allows a custom integration to be uploaded as a ZIP file containing configuration and dataset definitions in YAML format. It was discovered that specially crafted YAML dataset and config files allow a malicious user to perform arbitrary requests to internal systems and exfiltrate data outside the environment (also known as a Server-Side Request Forgery). The application does not perform proper validation to block attempts to connect to internal (including localhost) resources. The vulnerability has been patched in Fides version `2.22.1`.
Affected products
- ethyca fides: before 2.22.1 — fixed in 2.22.1
How to fix
Upgrade to a fixed version: ethyca fides 2.22.1. Check the vendor advisory for mitigations.
References
- https://github.com/ethyca/fides/commit/cd344d016b1441662a61d0759e7913e8228ed1ee
- https://github.com/ethyca/fides/releases/tag/2.22.1
- https://github.com/ethyca/fides/security/advisories/GHSA-jq3w-9mgf-43m4
- https://github.com/ethyca/fides/commit/cd344d016b1441662a61d0759e7913e8228ed1ee
- https://github.com/ethyca/fides/releases/tag/2.22.1
- https://github.com/ethyca/fides/security/advisories/GHSA-jq3w-9mgf-43m4
Get alerted when CVE-2023-46124 or the next vulnerability affects your stack