What’s Vulnerable › Vulnerabilities
CVE-2023-46125: Fides Information Disclosure Vulnerability in Config API Endpoint
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-25 · updated 2026-06-17
- Weakness: CWE-200
Description
Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in a runtime environment, and the enforcement of privacy regulations in code. The Fides webserver API allows users to retrieve its configuration using the `GET api/v1/config` endpoint. The configuration data is filtered to suppress most sensitive configuration information before it is returned to the user, but even the filtered data contains information about the internals and the backend infrastructure, such as various settings, servers’ addresses and ports and database username. This information is useful for administrative users as well as attackers, thus it should not be revealed to low-privileged users. This vulnerability allows Admin UI users with roles lower than the owner role e.g. the viewer role to retrieve the config information using the API. The vulnerability has been patched in Fides version `2.22.1`.
Affected products
- ethyca fides: before 2.22.1 — fixed in 2.22.1
How to fix
Upgrade to a fixed version: ethyca fides 2.22.1. Check the vendor advisory for mitigations.
References
- https://github.com/ethyca/fides/commit/c9f3a620a4b4c1916e0941cb5624dcd636f06d06
- https://github.com/ethyca/fides/releases/tag/2.22.1
- https://github.com/ethyca/fides/security/advisories/GHSA-rjxg-rpg3-9r89
- https://github.com/ethyca/fides/commit/c9f3a620a4b4c1916e0941cb5624dcd636f06d06
- https://github.com/ethyca/fides/releases/tag/2.22.1
- https://github.com/ethyca/fides/security/advisories/GHSA-rjxg-rpg3-9r89
Get alerted when CVE-2023-46125 or the next vulnerability affects your stack