What’s Vulnerable › Vulnerabilities
CVE-2023-46127: Frappe vulnerable to HTML injection by any Desk user
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 41.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Frappe is a full-stack web application framework that uses Python and MariaDB on the server side and an integrated client side library. A malicious Frappe user with desk access could create documents containing HTML payloads allowing HTML Injection. This vulnerability has been patched in version 14.49.0.
Affected products
- frappe: before 14.49.0 — fixed in 14.49.0
How to fix
Upgrade to a fixed version: frappe 14.49.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/commit/3dc5d2fcc7561dde181ba953009fe6e39d64e900
- https://github.com/frappe/frappe/pull/22339
- https://github.com/frappe/frappe/security/advisories/GHSA-j2w9-8xrr-7g98
- https://github.com/frappe/frappe/commit/3dc5d2fcc7561dde181ba953009fe6e39d64e900
- https://github.com/frappe/frappe/pull/22339
- https://github.com/frappe/frappe/security/advisories/GHSA-j2w9-8xrr-7g98
Get alerted when CVE-2023-46127 or the next vulnerability affects your stack