What’s Vulnerable › Vulnerabilities
CVE-2023-46130: Bypassing height value allowed in some theme components
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-10 · updated 2026-06-17
- Weakness: CWE-770
Description
Discourse is an open source platform for community discussion. Prior to version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches, some theme components allow users to add svgs with unlimited `height` attributes, and this can affect the availability of subsequent replies in a topic. Most Discourse instances are unaffected, only instances with the svgbob or the mermaid theme component are within scope. The issue is patched in version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches. As a workaround, disable or remove the relevant theme components.
Affected products
- discourse: before 3.1.3; before 3.2.0; 3.2.0-beta1, 3.2.0-beta2 — fixed in 3.1.3, 3.2.0
How to fix
Upgrade to a fixed version: discourse 3.1.3, 3.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/6183d9633de873ac2b1e9cdb6ac1c94b4ffae9cb
- https://github.com/discourse/discourse/commit/89a2e60706ce22e4afc463d03af2f34c53291800
- https://github.com/discourse/discourse/security/advisories/GHSA-c876-638r-vfcg
- https://github.com/discourse/discourse/commit/6183d9633de873ac2b1e9cdb6ac1c94b4ffae9cb
- https://github.com/discourse/discourse/commit/89a2e60706ce22e4afc463d03af2f34c53291800
- https://github.com/discourse/discourse/security/advisories/GHSA-c876-638r-vfcg
Get alerted when CVE-2023-46130 or the next vulnerability affects your stack