What’s Vulnerable › Vulnerabilities
CVE-2023-46131: Grails® data binding causes JVM crash and/or DoS
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-21 · updated 2026-06-17
- Weakness: CWE-400
Description
Grails is a framework used to build web applications with the Groovy programming language. A specially crafted web request can lead to a JVM crash or denial of service. Any Grails framework application using Grails data binding is vulnerable. This issue has been patched in version 3.3.17, 4.1.3, 5.3.4, 6.1.0.
Affected products
- grails-core: before 3.3.17; from 4.0.0 before 4.1.3; from 5.0.0 before 5.3.4; from 6.0.0 before 6.1.0 — fixed in 3.3.17, 4.1.3, 5.3.4, 6.1.0
How to fix
Upgrade to a fixed version: grails-core 3.3.17, 4.1.3, 5.3.4, 6.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/grails/grails-core/commit/74326bdd2cf7dcb594092165e9464520f8366c60
- https://github.com/grails/grails-core/commit/c401faaa6c24c021c758b95f72304a0e855a8db3
- https://github.com/grails/grails-core/issues/13302
- https://github.com/grails/grails-core/security/advisories/GHSA-3pjv-r7w4-2cf5
- https://grails.org/blog/2023-12-20-cve-data-binding-dos.html
- https://github.com/grails/grails-core/commit/74326bdd2cf7dcb594092165e9464520f8366c60
- https://github.com/grails/grails-core/commit/c401faaa6c24c021c758b95f72304a0e855a8db3
- https://github.com/grails/grails-core/issues/13302
- https://github.com/grails/grails-core/security/advisories/GHSA-3pjv-r7w4-2cf5
- https://grails.org/blog/2023-12-20-cve-data-binding-dos.html
Get alerted when CVE-2023-46131 or the next vulnerability affects your stack