What’s Vulnerable › Vulnerabilities
CVE-2023-46136: Werkzeug vulnerable to high resource usage when parsing multipart/form-data containing a large part with CR/LF character at the beginning
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-25 · updated 2026-06-17
- Weakness: CWE-400
Description
Werkzeug is a comprehensive WSGI web application library. In versions on the 3.x branch prior to 3.0.1 and on the 2.x branch prior to 2.3.8, if an upload of a file that starts with CR or LF and then is followed by megabytes of data without these characters: all of these bytes are appended chunk by chunk into internal bytearray and lookup for boundary is performed on growing buffer. This allows an attacker to cause a denial of service by sending crafted multipart data to an endpoint that will parse it. The amount of CPU time required can block worker processes from handling legitimate requests. This vulnerability has been patched in version 3.0.1 and 2.3.8.
Affected products
- pallets werkzeug: before 2.3.8; 3.0.0 — fixed in 2.3.8
- Pypi Werkzeug: before 2.3.8; from 3.0.0 before 3.0.1; 0.1, 0.10, 0.10.1, 0.10.2, 0.10.3, 0.10.4 (+84) — fixed in 2.3.8, 3.0.1
How to fix
Upgrade to a fixed version: pallets werkzeug 2.3.8; Pypi Werkzeug 2.3.8, 3.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/pallets/werkzeug/commit/f3c803b3ade485a45f12b6d6617595350c0f03e2
- https://github.com/pallets/werkzeug/security/advisories/GHSA-hrfv-mqp8-q5rw
- https://github.com/pallets/werkzeug/commit/f3c803b3ade485a45f12b6d6617595350c0f03e2
- https://github.com/pallets/werkzeug/security/advisories/GHSA-hrfv-mqp8-q5rw
- https://security.netapp.com/advisory/ntap-20231124-0008/
Get alerted when CVE-2023-46136 or the next vulnerability affects your stack