What’s Vulnerable › Vulnerabilities
CVE-2023-46158: IBM WebSphere Application Server session fixation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-25 · updated 2026-06-17
- Weakness: CWE-613
Description
IBM WebSphere Application Server Liberty 23.0.0.9 through 23.0.0.10 could provide weaker than expected security due to improper resource expiration handling. IBM X-Force ID: 268775.
Affected products
- IBM Websphere Application Server Liberty: from 23.0.0.9 before 23.0.0.11 — fixed in 23.0.0.11
How to fix
Upgrade to a fixed version: IBM Websphere Application Server Liberty 23.0.0.11. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/268775
- https://www.ibm.com/support/pages/node/7058356
- https://exchange.xforce.ibmcloud.com/vulnerabilities/268775
- https://www.ibm.com/support/pages/node/7058356
Get alerted when CVE-2023-46158 or the next vulnerability affects your stack