What’s Vulnerable › Vulnerabilities

CVE-2023-46213: Cross-site Scripting (XSS) on “Show Syntax Highlighted” View in Search Page

Description

In Splunk Enterprise versions below 9.0.7 and 9.1.2, ineffective escaping in the “Show syntax Highlighted” feature can result in the execution of unauthorized code in a user’s web browser.

Affected products

How to fix

Upgrade to a fixed version: Splunk Cloud 9.1.2308; Splunk Enterprise 9.0.7, 9.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-46213 or the next vulnerability affects your stack