What’s Vulnerable › Vulnerabilities
CVE-2023-46227: Apache inlong has an Arbitrary File Read Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-19 · updated 2026-06-17
- Weakness: CWE-502
Description
Deserialization of Untrusted Data Vulnerability in Apache Software Foundation Apache InLong. This issue affects Apache InLong: from 1.4.0 through 1.8.0, the attacker can use \t to bypass. Users are advised to upgrade to Apache InLong's 1.9.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/8814
Affected products
- Apache Software Foundation Apache InLong: from 1.4.0 before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache InLong 1.9.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/m8txor4f76tmrxksrmc87tw42g57nz33
- https://lists.apache.org/thread/m8txor4f76tmrxksrmc87tw42g57nz33
Get alerted when CVE-2023-46227 or the next vulnerability affects your stack