What’s Vulnerable › Vulnerabilities
CVE-2023-46229
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 47.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-19 · updated 2026-06-17
- Weakness: CWE-918
Description
LangChain before 0.0.317 allows SSRF via document_loaders/recursive_url_loader.py because crawling can proceed from an external server to an internal server.
Affected products
- langchain-ai/langchain: before 0.0.317 — fixed in 0.0.317
How to fix
Upgrade to a fixed version: langchain-ai/langchain 0.0.317. Check the vendor advisory for mitigations.
References
- https://github.com/langchain-ai/langchain/commit/9ecb7240a480720ec9d739b3877a52f76098a2b8
- https://github.com/langchain-ai/langchain/pull/11925
- https://github.com/langchain-ai/langchain/commit/9ecb7240a480720ec9d739b3877a52f76098a2b8
- https://github.com/langchain-ai/langchain/pull/11925
Get alerted when CVE-2023-46229 or the next vulnerability affects your stack