What’s Vulnerable › Vulnerabilities
CVE-2023-46233: crypto-js PBKDF2 1,000 times weaker than specified in 1993 and 1.3M times weaker than current standard
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-25 · updated 2026-06-23
- Weakness: CWE-328
Description
crypto-js is a JavaScript library of crypto standards. Prior to version 4.2.0, crypto-js PBKDF2 is 1,000 times weaker than originally specified in 1993, and at least 1,300,000 times weaker than current industry standard. This is because it both defaults to SHA1, a cryptographic hash algorithm considered insecure since at least 2005, and defaults to one single iteration, a 'strength' or 'difficulty' value specified at 1,000 when specified in 1993. PBKDF2 relies on iteration count as a countermeasure to preimage and collision attacks. If used to protect passwords, the impact is high. If used to generate signatures, the impact is high. Version 4.2.0 contains a patch for this issue. As a workaround, configure crypto-js to use SHA256 with at least 250,000 iterations.
Affected products
- brix crypto-js: before 4.2.0 — fixed in 4.2.0
How to fix
Upgrade to a fixed version: brix crypto-js 4.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/brix/crypto-js/commit/421dd538b2d34e7c24a5b72cc64dc2b9167db40a
- https://github.com/brix/crypto-js/security/advisories/GHSA-xwcq-pm8m-c4vf
- https://lists.debian.org/debian-lts-announce/2023/11/msg00025.html
- https://github.com/brix/crypto-js/commit/421dd538b2d34e7c24a5b72cc64dc2b9167db40a
- https://github.com/brix/crypto-js/security/advisories/GHSA-xwcq-pm8m-c4vf
- https://lists.debian.org/debian-lts-announce/2023/11/msg00025.html
Get alerted when CVE-2023-46233 or the next vulnerability affects your stack