What’s Vulnerable › Vulnerabilities
CVE-2023-46240: CodeIgniter4 vulnerable to information disclosure when detailed error report is displayed in production environment
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-31 · updated 2026-06-17
- Weakness: CWE-209
Description
CodeIgniter is a PHP full-stack web framework. Prior to CodeIgniter4 version 4.4.3, if an error or exception occurs, a detailed error report is displayed even if in the production environment. As a result, confidential information may be leaked. Version 4.4.3 contains a patch. As a workaround, replace `ini_set('display_errors', '0')` with `ini_set('display_errors', 'Off')` in `app/Config/Boot/production.php`.
Affected products
- CodeIgniter4: before 4.4.3 — fixed in 4.4.3
How to fix
Upgrade to a fixed version: CodeIgniter4 4.4.3. Check the vendor advisory for mitigations.
References
- https://codeigniter4.github.io/userguide/general/errors.html#error-reporting
- https://github.com/codeigniter4/CodeIgniter4/commit/423569fc31e29f51635a2e59c89770333f0e7563
- https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-hwxf-qxj7-7rfj
- https://codeigniter4.github.io/userguide/general/errors.html#error-reporting
- https://github.com/codeigniter4/CodeIgniter4/commit/423569fc31e29f51635a2e59c89770333f0e7563
- https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-hwxf-qxj7-7rfj
Get alerted when CVE-2023-46240 or the next vulnerability affects your stack