What’s Vulnerable › Vulnerabilities
CVE-2023-46287
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-20 · updated 2026-06-17
- Weakness: CWE-79
Description
XSS exists in NagVis before 1.9.38 via the select function in share/server/core/functions/html.php.
Affected products
- Nagvis: before 1.9.38 — fixed in 1.9.38
How to fix
Upgrade to a fixed version: Nagvis 1.9.38. Check the vendor advisory for mitigations.
References
- https://github.com/NagVis/nagvis/compare/nagvis-1.9.37...nagvis-1.9.38
- https://github.com/NagVis/nagvis/pull/356
- https://github.com/NagVis/nagvis/pull/356/commits/d660591b23e5cfea4d1be2d3fb8f3855aa6020fb
- https://github.com/NagVis/nagvis/compare/nagvis-1.9.37...nagvis-1.9.38
- https://github.com/NagVis/nagvis/pull/356
- https://github.com/NagVis/nagvis/pull/356/commits/d660591b23e5cfea4d1be2d3fb8f3855aa6020fb
- https://lists.debian.org/debian-lts-announce/2025/05/msg00000.html
Get alerted when CVE-2023-46287 or the next vulnerability affects your stack