What’s Vulnerable › Vulnerabilities
CVE-2023-46300
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-22 · updated 2026-06-17
- Weakness: CWE-116
Description
iTerm2 before 3.4.20 allow (potentially remote) code execution because of mishandling of certain escape sequences related to tmux integration.
Affected products
- iTerm2: before 3.4.20 — fixed in 3.4.20
How to fix
Upgrade to a fixed version: iTerm2 3.4.20. Check the vendor advisory for mitigations.
References
- https://blog.solidsnail.com/posts/2023-08-28-iterm2-rce
- https://github.com/gnachman/iTerm2/commit/ae8192522661c34d1cbe57f6f9ef2ff0a337c2a5
- https://github.com/gnachman/iTerm2/commit/b2268b03b5f3d4cd8ca275eaef5d16d0fac20009
- https://iterm2.com/news.html
- https://blog.solidsnail.com/posts/2023-08-28-iterm2-rce
- https://github.com/gnachman/iTerm2/commit/ae8192522661c34d1cbe57f6f9ef2ff0a337c2a5
- https://github.com/gnachman/iTerm2/commit/b2268b03b5f3d4cd8ca275eaef5d16d0fac20009
- https://iterm2.com/news.html
Get alerted when CVE-2023-46300 or the next vulnerability affects your stack