What’s Vulnerable › Vulnerabilities
CVE-2023-46303
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-22 · updated 2026-06-17
- Weakness: CWE-918
Description
link_to_local_path in ebooks/conversion/plugins/html_input.py in calibre before 6.19.0 can, by default, add resources outside of the document root.
Affected products
- kovidgoyal calibre: before 6.19.0 — fixed in 6.19.0
How to fix
Upgrade to a fixed version: kovidgoyal calibre 6.19.0. Check the vendor advisory for mitigations.
References
- https://github.com/0x1717/ssrf-via-img
- https://github.com/kovidgoyal/calibre/compare/v6.18.1...v6.19.0
- https://github.com/0x1717/ssrf-via-img
- https://github.com/kovidgoyal/calibre/compare/v6.18.1...v6.19.0
- https://lists.debian.org/debian-lts-announce/2024/09/msg00005.html
Get alerted when CVE-2023-46303 or the next vulnerability affects your stack