What’s Vulnerable › Vulnerabilities
CVE-2023-46306
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-22 · updated 2026-06-17
- Weakness: CWE-78
Description
The web administration interface in NetModule Router Software (NRSW) 4.6 before 4.6.0.106 and 4.8 before 4.8.0.101 executes an OS command constructed with unsanitized user input: shell metacharacters in the /admin/gnssAutoAlign.php device_id parameter. This occurs because another thread can be started before the trap that triggers the cleanup function. A successful exploit could allow an authenticated user to execute arbitrary commands with elevated privileges. NOTE: this is different from CVE-2023-0861 and CVE-2023-0862, which were fixed in version 4.6.0.105.
Affected products
- Netmodule Router Software: before 4.6.0.105; from 4.7.0.0 before 4.7.0.103 — fixed in 4.6.0.105, 4.7.0.103
How to fix
Upgrade to a fixed version: Netmodule Router Software 4.6.0.105, 4.7.0.103. Check the vendor advisory for mitigations.
References
- https://pentest.blog/advisory-netmodule-router-software-race-condition-leads-to-remote-code-execution/
- https://share.netmodule.com/public/system-software/4.6/4.6.0.106/NRSW-RN-4.6.0.106.pdf
- https://share.netmodule.com/public/system-software/4.8/4.8.0.101/NRSW-RN-4.8.0.101.pdf
- https://pentest.blog/advisory-netmodule-router-software-race-condition-leads-to-remote-code-execution/
- https://share.netmodule.com/public/system-software/4.6/4.6.0.106/NRSW-RN-4.6.0.106.pdf
- https://share.netmodule.com/public/system-software/4.8/4.8.0.101/NRSW-RN-4.8.0.101.pdf
Get alerted when CVE-2023-46306 or the next vulnerability affects your stack