What’s Vulnerable › Vulnerabilities
CVE-2023-46308
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-03 · updated 2026-06-17
- Weakness: CWE-1321
Description
In Plotly plotly.js before 2.25.2, plot API calls have a risk of __proto__ being polluted in expandObjectPaths or nestedProperty.
Affected products
- Plotly.Js: before 2.25.2 — fixed in 2.25.2
How to fix
Upgrade to a fixed version: Plotly.Js 2.25.2. Check the vendor advisory for mitigations.
References
- https://github.com/plotly/plotly.R/issues/2463
- https://github.com/plotly/plotly.js/releases/tag/v2.25.2
- https://plotly.com/javascript/
- https://github.com/plotly/plotly.js/releases/tag/v2.25.2
- https://plotly.com/javascript/
Get alerted when CVE-2023-46308 or the next vulnerability affects your stack