What’s Vulnerable › Vulnerabilities
CVE-2023-46316
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-25 · updated 2026-06-17
- Weakness: CWE-234
Description
In buc Traceroute 2.0.12 through 2.1.2 before 2.1.3, the wrapper scripts do not properly parse command lines.
Affected products
- Buc Traceroute: from 2.0.12 before 2.1.3 — fixed in 2.1.3
- Debian Linux: 10.0, 11.0, 12.0
How to fix
Upgrade to a fixed version: Buc Traceroute 2.1.3. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/176660/Traceroute-2.1.2-Privilege-Escalation.html
- https://security-tracker.debian.org/tracker/CVE-2023-46316
- https://sourceforge.net/projects/traceroute/files/traceroute/traceroute-2.1.3/
- http://packetstormsecurity.com/files/176660/Traceroute-2.1.2-Privilege-Escalation.html
- https://security-tracker.debian.org/tracker/CVE-2023-46316
- https://sourceforge.net/projects/traceroute/files/traceroute/traceroute-2.1.3/
Get alerted when CVE-2023-46316 or the next vulnerability affects your stack